1

Closed

Cannot run the Mapwindow application

description

Hi,
I have downloaded both of the installers (x86, x64) and tried with both of them but the application is not starting. giivng the error :

The expected field isn't found in the [Region] table.

Then crashes.

Can you help me to fix it?

file attachments

Closed Feb 18, 2016 at 8:30 AM by pmeems

comments

pmeems wrote Oct 23, 2015 at 6:55 AM

Thanks for reporting this.
We will have a look at it. Did you just started MapWindow or did you load a project with layers?

sleschinski wrote Oct 23, 2015 at 2:39 PM

I've added a try-catch block so that the app can be started (it was an overlook not to wrap the call in the first place). The database it is complaining about is in Projections subfolder (the default path is something like Program files\MapWindow\Projections\projections.db3). You can experiment trying to move it out of the folder and see if it changes things. In my current version the app can start without this database. Also it might help to attach the database to the issue so we can check if everything is ok with it.

As for the error report would be good to have stack trace on the inner most exception (can be viewed by selecting the line "Column "Region_Code" does not..."). Also the info about exception is copied to the clipboard when the error dialog appears, so no need to do a screenshot each time.

Thanks for reporting this.

ihsankurt wrote Oct 29, 2015 at 7:11 AM

hi all,

Firstly, I have removed the db from proejctions folder and software launches with an error.

MapWindow 5

A single database is expected. 0 databases are found.

Path : C:\Program Files (x86)\MapWindow5\Projections\

OK

But it works. The interface opens. I have attached the db here.

pmeems wrote Nov 17, 2015 at 8:55 PM

pmeems wrote Feb 11, 2016 at 2:18 PM

Can you check with the latest version: https://mapwindow5.codeplex.com/releases
It should be solved.