This project is read-only.

editing of dynamically ogr layers forbidden

Nov 11, 2015 at 9:39 AM
Edited Nov 11, 2015 at 10:07 AM
EDITED:
hi,could you please , enlighten me about editing for postgis ?
Nov 11, 2015 at 9:47 AM
Edited Nov 11, 2015 at 9:48 AM
That's unbeliveable, couldn't you just say "hi", "please" and "thanks" to those people who spend their spare time to develop this soft instead of sending those sort of rude complaint ???
Nov 11, 2015 at 10:02 AM
Edited Nov 11, 2015 at 1:30 PM
i'm sorry, i know we all are in a great debt to you; i had a feeling you are still hard working on it all, aren't you...
if it's of any help, i have a great consideration for you all , developers. thanks for all you're doing for me, and you...
is this better? i know how hard it is to code for asynchronous tasking, i've done it: it's extremely demanding, and doesn't forgive the slightest omission.
i suppose the postgis editing is already working, you're just polishing it, and integrating it into the rest of it.
Tell me, please, if you don't mind, the activex control is still 4.9 , on its way to becoming 5, isn't it?
Nov 12, 2015 at 1:08 PM
The MapWindow application consists of two major parts:
  1. MapWinGIS which is an ActiveX control written in C++ and is doing most of the work
  2. MW5 which is a wrapper for MapWinGIS and contains among others the GUI and the plug-in structure. This is all written in C#
The PostGIS part is in both parts. MapWinGIS is doing the actual opening and loading and MW5 is responsible for the GUI.

My first question is what are you using? MW5 or just MapWinGIS?
I'm assuming MW5. When you load a PostGIS layer and on the Shapefile Editor toolbar go to Edit mode can't you make changes?
Are you getting errors?

Thanks,

Paul
Nov 12, 2015 at 2:30 PM
Edited Nov 13, 2015 at 9:58 AM
Hi,thanks: you're assuming right: i am using MW5 ;
image1
image2

This is a formidably positive change in MW5: it is offering a beautiful interface for editing, with double-click point inserting, distance and surface area being displayed alongside all the time; qgis hasn't got this !
    Level   Message Time
1 Info APPLICATION STARTUP 04:19:49.367
2 Debug Source geographic CS for projected CS wasn't found: 5819 04:19:51.045
3 Debug Source geographic CS for projected CS wasn't found: 5820 04:19:51.046
4 Debug Source geographic CS for projected CS wasn't found: 5821 04:19:51.048
5 Warn No group is specified for the tool: Translate raster (MW4 UI) 04:19:52.258
6 Info Loading time: 00:00:02.9385990 04:19:52.369
7 Debug Checking for new version 04:19:52.474
8 Debug File version: 5.0.2.0 04:19:52.476
9 Debug New Last checked: 12-Nov-15 16:19:52 04:19:52.518
10 Debug Latest Stable version: 5.0.0.0 04:19:53.126
11 Debug Latest Beta version: 5.0.1.1 04:19:53.128
12 Debug No new installers available 04:19:53.130
13 Debug OGR layer has single geometry type. ActiveShapeType provided will be ignored. 04:20:07.135
14 Info Can't save settings for non disk-based layer 04:20:07.185
15 Debug OGR layer has single geometry type. ActiveShapeType provided will be ignored. 04:20:57.347
16 Info Can't save settings for non disk-based layer 04:20:59.005
17 Debug OgrLayer: OGR layer has no local modifications to be saved. 04:22:03.000
18 Debug OgrLayer: OGR layer has no local modifications to be saved. 04:23:10.687


After adding a geometry, MW5 reports: "All changes saved"... so new geometries are saved alright into the PostgreSql database table; vertex editor changes aren't saved. If you both edit and add features, then: "some changes saved".

Thanks,
Costea.